Code Monkey home page Code Monkey logo

openbsd-eigrpd's People

Contributors

rwestphal avatar

Stargazers

 avatar  avatar  avatar  avatar  avatar

Watchers

 avatar  avatar  avatar  avatar  avatar  avatar

openbsd-eigrpd's Issues

no redistribution of routes between two autonomous systems

Setup:
OpenBSD 6.4 amd64:
ifconfig em4 10.4.254.254/24
ifconfig em5 10.15.254.254/24
obsd64# cat /etc/eigrpd.conf | grep -v "#"
router-id 10.0.0.1
address-family ipv4 {
autonomous-system 2 {
redistribute connected
interface em4
}
autonomous-system 3 {
redistribute connected
interface em5
}
}

obsd64# sysctl net.inet.ip.forwarding
net.inet.ip.forwarding=1

obsd64# pfctl -d
pfctl: pf not enabled

CISCO 1st router:
interface GigabitEthernet0/0
ip address 10.4.254.6 255.255.255.0
media-type gbic
speed 1000
duplex full
negotiation auto
end
interface GigabitEthernet1/0
ip address 192.168.6.254 255.255.255.0
negotiation auto
!
router eigrp 2
default-metric 100000 10 255 1 1500
network 10.4.254.0 0.0.0.255
redistribute connected
!

CISCO 2st router:
interface GigabitEthernet0/0
ip address 10.15.254.2 255.255.255.0
media-type gbic
speed 1000
duplex full
negotiation auto
interface GigabitEthernet1/0
ip address 192.168.5.254 255.255.255.0
negotiation auto
router eigrp 3
default-metric 100000 10 255 1 1500
network 10.15.254.0 0.0.0.255
redistribute connected

Verification:
On OpenBSD box:

obsd64# eigrpd -dvvv -f /etc/eigrpd.conf
startup
eigrp_if_start: em5 as 3 family ipv4
if_join_ipv4_group: interface em5 addr 224.0.0.10
eigrp_if_start: em4 as 2 family ipv4
if_join_ipv4_group: interface em4 addr 224.0.0.10
rt_new: prefix 10.15.254.0/24
route_new: prefix 10.15.254.0/24 via connected distance (28160/0)
rt_new: prefix 10.4.254.0/24
route_new: prefix 10.4.254.0/24 via connected distance (28160/0)
nbr_new: interface em4 addr 10.4.254.6 as 2
send_packet: type UPDATE iface em4 nbr 10.4.254.6 AS 2 seq 1 ack 0
nbr_new: interface em5 addr 10.15.254.2 as 3
send_packet: type UPDATE iface em5 nbr 10.15.254.2 AS 3 seq 1 ack 0
recv_packet_eigrp: type UPDATE nbr 10.4.254.6 AS 2 seq 3 ack 0
recv_update: INIT flag is set
recv_packet_eigrp: type UPDATE nbr 10.15.254.2 AS 3 seq 5 ack 0
recv_update: INIT flag is set
recv_packet_eigrp: type UPDATE nbr 10.15.254.2 AS 3 seq 6 ack 0
rt_new: prefix 192.168.5.0/24
route_new: prefix 192.168.5.0/24 via 10.15.254.2 distance (28416/2816)
rde_send_change_kroute: 192.168.5.0/24 nbr 10.15.254.2
recv_packet_eigrp: type UPDATE nbr 10.4.254.6 AS 2 seq 4 ack 0
rt_new: prefix 192.168.6.0/24
route_new: prefix 192.168.6.0/24 via 10.4.254.6 distance (28416/2816)
rde_send_change_kroute: 192.168.6.0/24 nbr 10.4.254.6
send_packet: type UPDATE iface em4 nbr 10.4.254.6 AS 2 seq 1 ack 4
rtp_process_ack: nbr 10.4.254.6 ack 1
send_packet: type UPDATE iface em4 nbr 10.4.254.6 AS 2 seq 2 ack 4
rtp_process_ack: nbr 10.4.254.6 ack 2
send_packet: type UPDATE iface em5 nbr 10.15.254.2 AS 3 seq 1 ack 6
rtp_process_ack: nbr 10.15.254.2 ack 1
send_packet: type UPDATE iface em5 nbr 10.15.254.2 AS 3 seq 2 ack 6
rtp_process_ack: nbr 10.15.254.2 ack 2

obsd64# eigrpctl sh int
AF AS Interface Address Linkstate Uptime nc
ipv4 2 em4 10.4.254.254/24 active 00:57:16 1
ipv4 3 em5 10.15.254.254/24 active 00:19:39 1
obsd64# eigrpctl sh nei
AF AS Address Iface Holdtime Uptime
ipv4 2 10.4.254.6 em4 15 00:14:14
ipv4 3 10.15.254.2 em5 15 00:16:35
obsd64# eigrpctl sh fib ei
flags: * = valid, D = EIGRP, C = Connected, S = Static
Flags Prio Destination Nexthop
*D EX 28 192.168.5.0/24 10.15.254.2
*D EX 28 192.168.6.0/24 10.4.254.6

On CISCO 1st router:

R6#sh ip eigrp int
EIGRP-IPv4 Interfaces for AS(2)
Xmit Queue PeerQ Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable Un/Reliable SRTT Un/Reliable Flow Timer Routes
Gi0/0 1 0/0 0/0 8 0/0 50 0

R6#sh ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(2)
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 10.4.254.254 Gi0/0 13 00:17:24 8 150 0 6

R6#sh ip eigrp topology all-links
EIGRP-IPv4 Topology Table for AS(2)/ID(192.168.6.254)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

P 10.4.254.0/24, 1 successors, FD is 2816, serno 2
via Connected, GigabitEthernet0/0
via 10.4.254.254 (28416/28160), GigabitEthernet0/0
P 192.168.6.0/24, 1 successors, FD is 2816, serno 1
via Rconnected (2816/0)

On CISCO 2st router:

R5#sh ip eigrp interfaces
EIGRP-IPv4 Interfaces for AS(3)
Xmit Queue PeerQ Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable Un/Reliable SRTT Un/Reliable Flow Timer Routes
Gi0/0 1 0/0 0/0 15 0/0 64 0

R5#sh ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(3)
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 10.15.254.254 Gi0/0 10 00:23:06 15 100 0 10

R5#sh ip eigrp topology all-links
EIGRP-IPv4 Topology Table for AS(3)/ID(192.168.5.254)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

P 192.168.5.0/24, 1 successors, FD is 2816, serno 3
via Rconnected (2816/0)
P 10.15.254.0/24, 1 successors, FD is 2816, serno 4
via Connected, GigabitEthernet0/0
via 10.15.254.254 (28416/28160), GigabitEthernet0/0

Conclusion:
As seen on the OpenBSD there are routes from both autonomous systems.
On CISCO routers there are no routes to another autonomous system.

What's my mistake?

Recommend Projects

  • React photo React

    A declarative, efficient, and flexible JavaScript library for building user interfaces.

  • Vue.js photo Vue.js

    ๐Ÿ–– Vue.js is a progressive, incrementally-adoptable JavaScript framework for building UI on the web.

  • Typescript photo Typescript

    TypeScript is a superset of JavaScript that compiles to clean JavaScript output.

  • TensorFlow photo TensorFlow

    An Open Source Machine Learning Framework for Everyone

  • Django photo Django

    The Web framework for perfectionists with deadlines.

  • D3 photo D3

    Bring data to life with SVG, Canvas and HTML. ๐Ÿ“Š๐Ÿ“ˆ๐ŸŽ‰

Recommend Topics

  • javascript

    JavaScript (JS) is a lightweight interpreted programming language with first-class functions.

  • web

    Some thing interesting about web. New door for the world.

  • server

    A server is a program made to process requests and deliver data to clients.

  • Machine learning

    Machine learning is a way of modeling and interpreting data that allows a piece of software to respond intelligently.

  • Game

    Some thing interesting about game, make everyone happy.

Recommend Org

  • Facebook photo Facebook

    We are working to build community through open source technology. NB: members must have two-factor auth.

  • Microsoft photo Microsoft

    Open source projects and samples from Microsoft.

  • Google photo Google

    Google โค๏ธ Open Source for everyone.

  • D3 photo D3

    Data-Driven Documents codes.