Code Monkey home page Code Monkey logo

network_tech's Introduction

Network Tech Documentation

Network Tech is a Package for Sublime Text providing Cisco config highlighting, auto completions and more.

Apache 2.0 License

Quick Start

  1. Install Sublime Text

  2. Activate Package Control in Sublime Text

  3. Install the package:

    File Menu: ToolsCommand Pallet

    ⌨️ Package Control: Install Package

    ⌨️ <enter>

    ⌨️ Network Tech

    ⌨️ <enter>

  4. Enable the syntax highlighting

    File Menu: ToolsCommand Pallet

    ⌨️ Set Syntax: Cisco IOS

    ⌨️ <enter>

😎

network_tech's People

Contributors

danieldjewell avatar eckelcu avatar heyglen avatar merriry avatar nnit-netgrp avatar

Stargazers

 avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar

Watchers

 avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar

network_tech's Issues

other vendors

Hi,

I know it is not directly related to the topic but would it be possible to implement the whole thing for other manufacturers? I would be very happy about a positive answer.

Many greetings

IOS Syntax Additions - Voice & Others

Which Syntax?:

IOS

Expected behavior and actual behavior:

Highlighting. Actual, none?

Steps to reproduce the problem:

config directives for CME like dial-peer ephone telephony-service are absent

New Feature Description:

I forked a copy, I'm going to play around with some of the options, I'd be honored if you'd consider including them. Might take me a little while.

Colors

Hi, this is not an issue, love the package, I can't seem to find where you're setting the colors (if you are), I'd love to port them to SEcureCRT and iterm2 so I have a consistent experience.

IPSLA

Would be interested in contributing, but i have no idea where to start. If any one wants to be give me some pointers that would be awesome.
If the below could be done that would be fantastic. Work regularly with upwards of 20 of these per router and having them highlighted would be very handy.

Which Syntax?:

IOS Classic

Expected behavior and actual behavior:

Expected to be highlighed
Actually not being highlighted

Steps to reproduce the problem:

Type in the commands in the example

New Feature Description:

Highlighted in the same fashion as the

Example Syntax

ip sla 1
icmp-echo 10.102.64.114 source-interface Tunnel710
tos 184
vrf agr_usi_vpn
threshold 2000
frequency 5
ip sla schedule 1 life forever start-time now

Link to command reference

Can no longer load

Getting error

Error loading syntax file "Packages/sublime-network/cisco/asa/syntax/CiscoASA.tmLanguage": Unable to open Packages/sublime-network/cisco/asa/syntax/CiscoASA.tmLanguage

Happened when I upgraded to Sublime text 3 build 3114 from 3103

Change text color

Hello,

Network Tech package is great but I would like to customize the color for certain keywords. Example, for "VLAN" I would like to choose a different color than what's in the package. Is this possible? I tried looking through the package files but haven't found the file that needs to be edited yet.

cisco IOS password 7 decode

Which Syntax?:

cisco IOS password 7 decode

Expected behavior and actual behavior:

password decode algorithm is incomplete

Steps to reproduce the problem:

try to decode a longer password with a high salt, or make it > ~20 char

Fix:

Run the following command on a switch:

username test privilege 15 password aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa

(80 "a") Look at result in config:

username test privilege 15 password 7 08204D4F08180416130A0D052B2A2529323423120617020057585952550F021917585956525354550A5A07065956051207055A0A070E204D4F08180416130A0D052B2A2529323423120617020057585952

This password has a salt of 8 and starts repeating at the 106(53) char (broke up hash for clarity):

08
204D4F08180416130A0D052B2A2529323423120617020057585952550F021917585956525354550A5A07065956051207055A0A070E
204D4F08180416130A0D052B2A2529323423120617020057585952

Since algorithm is well known, run algorithm backwards on section to recover key:

a="204D4F08180416130A0D052B2A2529323423120617020057585952550F021917585956525354550A5A07065956051207055A0A070E"
ciscopwkey=""
for i in range(0,len(a),2):
	ciscopwkey+=(chr(int(a[i] + a[i+1],16) ^ ord("a")))
print ciscopwkey

result:

A,.iyewrkldJKDHSUBsgvca69834ncxv9873254k;fg87dsfd;kfo

since salt was 8, the last 8 char get moved to the front:

dsfd;kfoA,.iyewrkldJKDHSUBsgvca69834ncxv9873254k;fg87

use this in the decode algorithm:

salt= int(password[0:2])
TRANSLATION_KEY="dsfd;kfoA,.iyewrkldJKDHSUBsgvca69834ncxv9873254k;fg87"
decoded_password = ''
for password_index in range(2,len(password),2):
    decoded_password += chr(int(password[password_index] + password[password_index+1], 16) ^ ord(TRANSLATION_KEY[salt]))
    salt += 1
    if salt==53:salt=0
print decoded_password

results(these were entered on a switch):

username test privilege 15 password 7 140713181F13253920

returns:

password
username test privilege 15 password 7 061207285F471A1817121307001D26242A2F23343100101911054251594743011614125757455E53595812591402595C091C15105F0E050025494F051E0A051B1F04093929313C2430230102110C0E524D57545B4F

returns:

thisisareallylongpasswordthatwouldnormallybreakmostdecodealgorithmsbutwearegoodtogo!

Code is all yours, don't even need attribution

Password Decode not parsing

Which Syntax?:

mode 7 Password Decode

Expected behavior and actual behavior:

A line like:
username privilege 15 password 7
Should be detected by the password decode algorithm and decoded.
Currently it is not.

Does not auto-complete `end` command

Which Syntax?:

IOS / ASA OS

Expected behavior and actual behavior:

The end command should be available / present as a potential command recognized for the auto-complete options

Steps to reproduce the problem:

Type end and the auto-complete options present enable and passwd

New Feature Description:

Add end as an auto-complete option

Example Syntax

conf t
object-group network customer_whitelist
 network-object host 10.10.10.10
 end

Link to command reference

Surprisingly more difficult that I anticipated, but this link talks about exiting global configuration mode using the end command:

https://www.cisco.com/c/en/us/td/docs/security/asa/asa72/configuration/guide/conf_gd/start.html

Network Find not working and mouse over IP info not working

Which Syntax?:

Cisco IOS

Expected behavior and actual behavior:

No mouse over actions on IP addresses and no Network Find in command window

Steps to reproduce the problem:

New Feature Description:

Example Syntax

Link to command reference

Sublime Version:
startup, version: 3200 osx x64 channel: stable

Console output:
reloading plugin Network Tech.network_tech
Traceback (most recent call last):
File "/Applications/Sublime Text.app/Contents/MacOS/sublime_plugin.py", line 125, in reload_plugin
m = importlib.import_module(modulename)
File "./python3.3/importlib/init.py", line 90, in import_module
File "", line 1584, in _gcd_import
File "", line 1565, in _find_and_load
File "", line 1532, in _find_and_load_unlocked
File "/Applications/Sublime Text.app/Contents/MacOS/sublime_plugin.py", line 1199, in load_module
exec(compile(source, source_path, 'exec'), mod.dict)
File "/Users/user/Library/Application Support/Sublime Text 3/Installed Packages/Network Tech.sublime-package/network_tech.py", line 10, in
File "/Applications/Sublime Text.app/Contents/MacOS/sublime_plugin.py", line 1199, in load_module
exec(compile(source, source_path, 'exec'), mod.dict)
File "/Users/user/Library/Application Support/Sublime Text 3/Installed Packages/Network Tech.sublime-package/lib/search/network/init.py", line 3, in
File "/Applications/Sublime Text.app/Contents/MacOS/sublime_plugin.py", line 1199, in load_module
exec(compile(source, source_path, 'exec'), mod.dict)
File "/Users/user/Library/Application Support/Sublime Text 3/Installed Packages/Network Tech.sublime-package/lib/search/network/listener.py", line 10, in
File "/Applications/Sublime Text.app/Contents/MacOS/sublime_plugin.py", line 1199, in load_module
exec(compile(source, source_path, 'exec'), mod.dict)
File "/Users/user/Library/Application Support/Sublime Text 3/Installed Packages/Network Tech.sublime-package/lib/search/network/network.py", line 16, in
ImportError: No module named 'network_tech'

Syntax Highlight: Dot1x Commands

Which Syntax?:

Highlighting of relevant Dot1x commands

Expected behavior and actual behavior:

Would find it very beneficial if Dot1x commands at both global config and swithport config level were highlighted. We work daily with network access controls (NAC). Currently most of the Dot1x specific commands are not highlighted.

Steps to reproduce the problem:

New Feature Description:

Highlighting of Dot1x related commands

Example Syntax

server name
aaa authentication
aaa authorization
aaa accounting
aaa server radius dynamic-author
device-sensor filter-list
tlv name
option name
option number
device-sensor filter-spec
device-sensor
access-session
access-session accounting
dot1x
mab
service-template
class-map
template
source template
aaa
authentication
authorization
radius-server
radius
voice
data

Link to command reference

most of the commands can be found in this general dot1x guide: https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/sec_usr_8021x/configuration/xe-3se/3850/sec-user-8021x-xe-3se-3850-book/config-ieee-802x-pba.html

All should be in the Cisco security command reference: https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/security/a1/sec-a1-cr-book.html

From there you should be able to get to the other book sections for the rest of the alphabet.

If you need more specific details, please feel free to reach out at any time.

Thank You!

Voice Additions

So, I finally had some time and got around to those voice additions in #7 ... sorry about the delay. 😁

I wanted to get some feedback before I did a PR -- I have not yet finished the changes to the syntax_test file (which would be part of a PR)

danieldjewell@778526f

Syntax Highlight: Port-Security on Switches

Which Syntax?:

IOS

Expected behavior:

Syntax Highlight

Actual behavior:

No Syntax Highlight

New Feature Description:

Port-Security is used to restrict input to an interface via MAC addresses.
As of the current release there is no syntax highlight for this feature.

Example Syntax

Notation Used

{} :: optional
[] :: mandatory
| :: option separator
<mac_address> :: 48-bit MAC address with H.H.H notation
<aging_time>, <maximum_addresses>, <packets_per_sec> :: <1 .. verylargeinteger>

Example Interface Configuration

interface GigabitEthernet 0/1
switchport mode access
! enables port-security, no syntax highlight from this point on, with the exception of the switchport keyword and no line
switchport port-security
! aging
switchport port-security aging [ static | time <aging_time> | type {absolute | inactivity} ]
! mac-address
switchport port-security mac-address [ <mac_address>  | sticky {<mac_address>} ]
! maximum
switchport port-security maximum { <maximum_addresses> }
! violation
switchport port-security violation [ protect | restrict | shutdown ]
! limit rate invalid-source-mac
switchport port-security limit rate invalid-source-mac [ none | <packets_per_sec> ]
end
! tabular information of all interfaces
show port-security address
! information of a specific interface
show port-security {address} interface interface_id

Link to command reference

Catalyst 4500 Series Switch Cisco IOS Software Configuration Guide

Network / Subnet Information Not Provided

Which Syntax?: Cisco IOS

Expected behavior and actual behavior:

Mousing over or typing in an IP Address and seeing the pertinent network information appear in a pop-up as shown here: https://network-tech.readthedocs.io/en/latest/context_info.html

No information is popping up (not even a blank box).

System information: macOS Mojave 10.14.2
Sublime Text 3 ver 3.1.1 Build 3176
Network Tech package installed via Package Control 1/4/2019

Steps to reproduce the problem:

Type line entry "ip address 10.0.0.1 255.255.255.0"

No information is displayed when moused over, typed, or highlighted. Auto-complete information is displayed while typing line as expected.

New Feature Description:

N/A

Example Syntax

Link to command reference

https://network-tech.readthedocs.io/en/latest/context_info.html

Provide Manual Installation Instructions

I have 2 work-issued laptops (on-network and off-network). One uses a permanent Cisco VPN (on-network) and the other uses standard windows networking (off-network). I can of course install anything at anytime on the off-network laptop, but the on-network uses the VPN and blocks access to GitHub, so I cannot install packages using package manager. I am in IT, just not the cyber dept., and have "full" local admin rights on both laptops.

Syntax Highlight: Access Control Lists

Which Syntax?:

IOS

Expected behavior and actual behavior:

Highlight. Actual, none?

Steps to reproduce the problem:

Review configuration containing ACLs.

New Feature Description:

Would love to see syntax highlighting for Access Control lists. Something that highlights that it is an ACL, if it's permit / deny, the IPs / object-groups contained, etc...

Syntax file loading error when the syntax is auto recognized from text

Which Syntax?:

All the ones included in the Network tech package

Expected behavior and actual behavior:

Opening Sublime Text and pasting a Cisco configuration in a blank file should result in the syntax type being auto recognized and the correct syntax selected. Instead, the following exception is thrown and a wrong syntax is displayed in the lower right corner of the window (Ex cisco-ios instead of Cisco IOS).
The syntax works perfectly if selected manually. I've already tried reinstalling Sublime Text from scratch

Error dump

error: Error loading syntax file "Packages/network_tech/cisco-ios.sublime-syntax": Unable to read Packages/network_tech/cisco-ios.sublime-syntax
Traceback (most recent call last):
File "C:\Users\Enrico Gasparini\OneDrive\Programmi\PortableApps\Sublime Text Portable\sublime_plugin.py", line 490, in run_async_view_listener_callback
vel.class.dictname
File "C:\Users\Enrico Gasparini\OneDrive\Programmi\PortableApps\Sublime Text Portable\Data\Installed Packages\Network Tech.sublime-package\network_tech.py", line 236, in on_modified_async
self.network_info()
File "C:\Users\Enrico Gasparini\OneDrive\Programmi\PortableApps\Sublime Text Portable\Data\Installed Packages\Network Tech.sublime-package\network_tech.py", line 239, in network_info
if not self.view.scope_name(point).startswith(SCOPE_PREFIX):
File "C:\Users\Enrico Gasparini\OneDrive\Programmi\PortableApps\Sublime Text Portable\sublime.py", line 884, in scope_name
return sublime_api.view_scope_name(self.view_id, pt)
TypeError: an integer is required (got type NoneType)

Steps to reproduce the problem:

Install a new portable copy of Sublime Text 3 build 3176
Install package control and Network Tech
Create a new file
Paste a cisco IOS configuration in it
Error occours

Attached files

Sample configuration causing the error : Sample.txt
Zipped mp4 screencast of the error: Error screencast.zip

Missing/Incomplete Highlighting for IOS XR Hundred/FortyGig.

"{ Incomplete } Syntax Highlighting"

IOS-XR

Example

interface HundredGigE0/0/0/0

Expected behavior and actual behavior

Expect the interface to be color coded like other interfaces. Interface is not highlighted.

Steps to reproduce the problem

Load any IOS XR config with hundredgig interfaces.

What is the problem?
Hundredgig interfaces are not highlighted and there for the following config lines associated with the interface are not highlighted either.

How might it be solved?
Please add hundredgig interface support.

P.S FortyGig has incomplete highlighting as well but at least it has some which allows for the remainder of its associated config to be highlighted.
interface FortyGigE0/0/0/10
Highlighting stops at Fo.

Screen Shot 2021-05-05 at 4 30 17 PM

New / Incomplete IOS-XR Syntax Highlighting

IOS-XR Example 1

  • add TwentyFiveGigE interface type
interface TwentyFiveGigE0/0/0/40
  • to cisco-ios-xr.sublime-syntax:
interface_names: |
    (?:TwentyFiveGigE)|
    (?:TwentyFiveGigEthernet)|
    (?:Twe)|

IOS-XR Example 2 (ASR 9K) - L2VPN and EVPN

Sorry I cant figure out how you setup this in your file.
You have to do your magic.

l2vpn
 bridge group 6005
  bridge-domain 6005
   interface Bundle-Ether2.1
    evi 6005
!
interface BVI34
 host-routing
 vrf 30
 ipv4 address 10.0.0.5 255.0.0.0
 arp learning local
 local-proxy-arp
 mac-address 1.1.1
!
!
evpn
 interface Bundle-Ether1
   ethernet-segment
   identifier type 0 40.00.00.00.00.00.00.00.01
   load-balancing-mode single-active
   bgp route-target 4000.0000.0001
 !
 evi 6005
  bgp
   rd 200:50
   route-target import 100:6005
   route-target export 100:6005
!
!
interface bundle-ether2.1 l2transport
  no shutdown
  encapsulation dot1q 1
  rewrite ingress tag pop 1 symmetric
!

Link to Command Reference

https://www.cisco.com/c/en/us/td/docs/routers/asr9000/software/asr9k-r7-5/lxvpn/configuration/guide/b-l2vpn-cg-asr9000-75x/configure-evpn-irb.html#task_7CAD3A1F2C9C4A939EAFE97BDA35B8BA

IOS-XR Syntax

There seems to be a lot of missing syntax highlighting in IOS-XR.

Example Syntax

Task Groups, User Groups, & Users (missing)

taskgroup TASK_GROUP_NAME
 description LINE
 inherit taskgroup WORD
 task debug|execute|read|write WORD
!
usergroup USER_GROUP_NAME
 description LINE
 inherit usergroup WORD
 taskgroup WORD
!
username A_USER
 group WORD
 password 0|7 LINE
 password LINE
 password-policy WORD
!

Clock (missing)

https://www.cisco.com/c/en/us/td/docs/routers/xr12000/software/xr12k_r3-9/system_management/command/reference/yr39xr12k_chapter4.html#wp748744425

clock timezone WORD <-23,+23> <0-59>|<cr>
clock summer-time WORD date <MONTHDAY> <1993-2035> <0-23>:<0-59> <MONTHDAY> <1993-2035> <0-23>:<0-59> <0-1440>|<cr>
clock summer-time WORD recurring <WEEKMONTH> <0-23>:<0-59> <WEEKMONTH> <0-23>:<0-59> <0-1440>|<cr> 

In the above, <MONTHDAY> can be either <1-31> <january-december> or <january-december> <1-31> (mix & match is allowed).
<WEEKMONTH> should be replaced with <1-5>|first|last <sunday-saturday> <january-december>.

Object-Groups (missing)

https://www.cisco.com/en/US/docs/ios-xml/ios/sec_data_acl/configuration/15-2mt/sec-object-group-acl.html

object-group network ipv4|ipv6 WORD
 description LINE
 host X.X.X.X|X:X::X # Depends on ipv4|ipv6
 object-group WORD
 range X.X.X.X|X:X::X X.X.X.X|X:X::X # Depends on ipv4|ipv6
 X.X.X.X/length|X:X::X/length # Depends on ipv4|ipv6
!
object-group port WORD
 description LINE
 eq|gt|lt|neq <portname>|<0-65535>
 object-group WORD
 range <portname>|<0-65535> <portname>|<0-65535>
!

IP Access Lists (missing)

(todo)

Netflow: Exporter-Map, Monitor-Map, Sampler-Map (missing)

(todo)

Interfaces (incomplete)

Applying access lists:

interface TenGigE0/0/0/0
 ipv4|ipv6 access-group WORD ingress|egress
 ipv4|ipv6 access-group WORD WORD ingress|egress
 ipv4|ipv6 access-group WORD WORD WORD ingress|egress
 ipv4|ipv6 access-group WORD WORD WORD WORD ingress|egress
 ipv4|ipv6 access-group WORD WORD WORD WORD WORD ingress|egress
 ipv4|ipv6 access-group WORD WORD WORD WORD WORD WORD ingress|egress
!

Port bundle configuration:

interface TenGigE0/0/0/0
 bundle id <1-65535> mode|<cr> active|inherit|on|passive
 bundle port-priority <1-65535>
!

Some interface names aren't highlighted correctly:

interface MgmtEth0/RSP0/CPU0/0
 shutdown
!
interface MgmtEth0/RSP0/CPU0/1
 shutdown
!
interface MgmtEth0/RSP1/CPU0/0
 shutdown
!
interface MgmtEth0/RSP1/CPU0/1
 shutdown
!
interface PTP0/RSP0/CPU0/0
 shutdown
!
interface PTP0/RSP1/CPU0/0
 shutdown
!

Netflow configuration:

interface TenGigE0/0/0/0
 flow ipv4|ipv6|mpls monitor WORD ingress|egress
 flow ipv4|ipv6|mpls monitor WORD sampler WORD ingress|egress
!

Other random/assorted interface config:

interface TenGigE0/0/0/0
 load-interval <0-600> # Must be a multiple of 30
 lldp
  receive disable
  transmit disable
  destination mac-address
   ieee-nearest-bridge
   ieee-nearest-non-tmpr-bridge
  !
 !
!

Prefix Sets (incomplete)

ge followed by le (or vice versa) isn't highlighted, and isn't highlighted for IPv6 at all:

prefix-set PREFIX_SET_NAME
 10.0.0.0/8 ge 24 le 32,  # "le 32" not highlighted correctly
 172.16.0.0/12 ge 24,     # Highlighted correctly
 ::0/0 ge 48 le 128,      # "ge 48" and "le 128" both not highlighted
 ::0/0 ge 48              # "ge 48" not highlighted correctly
end-set

Route Policies (incomplete)

There should not be a space between the route policy name and variables:

route-policy RP_NAME($VAR)
end-policy

A lot more things are highlighting incorrectly, so I'll just post screenshots rather than trying to explain them all:
image

Router BGP

Missing the following attributes:

router bgp 1
 address-family ipv4 unicast
  additional-paths receive # Not implemented
  additional-paths send # Not implemented
  additional-paths selection route-policy WORD # Not implemented
  redistribute static route-policy WORD # Not implemented
 !
 neighbor 1.1.1.1
  ignore-connected-check             # Not implemented
  address-family ipv4 unicast
   default-originate                 # Not implemented
   send-community-ebgp               # Not implemented
   send-extended-community-ebgp      # Not implemented
   route-reflector-client            # Not implemented
   route-policy test(1234, 1234) in  # Multiple parameters aren't supported
   remove-private-AS                 # Not implemented
   remove-private-AS inbound         # Not implemented

Syntax Highlight: Simple Network Management Protocol

Which Syntax?:

IOS

Expected behavior and actual behavior:

Highlight. Actual, none?

Steps to reproduce the problem:

Review config containing SNMP configuration.

New Feature Description:

Would like to see SNMP configuration lines highlighted. Highlighting that it is an SNMP line, if changes were added / removed,

Classic ios syntax missing

Which Syntax?:

I missing alot of security features for switches and routers.

Like interface syntax such as

int Gix/x
 switchport nonegotiate
 load-interval 30
 ip dhcp snooping trust
 storm-control broadcast level 50.00
 storm-control multicast level 50.00
 storm-control action trap
 storm-control action shutdown

also in the global errordisable features are not recognized

errdisable recovery cause bpduguard
errdisable recovery cause security-violation
errdisable recovery cause link-flap
errdisable recovery cause psecure-violation
errdisable recovery cause mac-limit
errdisable recovery cause storm-control
errdisable recovery cause loopback
errdisable recovery cause loopdetect

ip dhcp snooping syntax are not working in global.

ip dhcp snooping
ip dhcp snooping vlan 1-4094

some logging syntaxes

logging host <HIDDEN_IP>
! C2960X
logging discriminator MAB facility drops DOT1X|MAB 
logging buffered discriminator MAB 20000

! C9300
logging discriminator MAB facility drops DOT1X|SESSION_MGR 
logging buffered discriminator MAB 20000

Also archive are not working

archive
 log config
  logging enable
  logging size 200
  notify syslog contenttype plaintext
  hidekeys
 path scp://<CREDS>@<HIDDEN_IP>//HIDDEN/PATH/$h_$t.confg
 write-memory

Kron jobs are not recognized

kron occurrence BACKUP_CONFIG at 22:00 recurring
 policy-list BACKUP
!
kron policy-list BACKUP
 cli archive log config add comment ----RUNNING_BACKUP----
 cli wr
!

Under LINE config transport none not working

line aux 0
 transport input none
 transport output none 
!

Banner login are not working

banner login ^C
*********************************************************
LOGIN MESSAGE REMOVED
*********************************************************
^C

tacacs syntax are not recognized

tacacs server HIDDENSERVER
 address ipv4 HIDDENIP
 key 7 025A1758190F1F35124F051C17035A4C1417396B2D3B732727616C27293C2F7363726970743E
 timeout 7
!
tacacs server HIDDENSERVER
 address ipv4 HIDDENIP
 key 7 025A1758190F1F35124F051C17035A4C1417396B2D3B732727616C27293C2F7363726970743E
 timeout 7
!
aaa group server tacacs+ TACACS_GROUP
 server name HIDDENSERVER
 server name HIDDENSERVER
!         
aaa authentication enable default group TACACS_GROUP enable 
aaa authorization exec default group TACACS_GROUP local if-authenticated 
aaa authorization commands 1 default group TACACS_GROUP local if-authenticated 
aaa authorization commands 15 default group TACACS_GROUP local if-authenticated 
aaa accounting exec default start-stop group TACACS_GROUP
aaa accounting commands 1 default start-stop group TACACS_GROUP
aaa accounting commands 15 default start-stop group TACACS_GROUP
aaa accounting send stop-record authentication failure
aaa authorization config-commands

Link to command reference

Here is the book for all command referance
https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/mcl/allreleasemcl/all-book.html

Also links to specific sections

Customize your package ?

Hi :) Thx for your package, i have a request.

Which Syntax?:

IOS classic

New Feature Description:

I'm newbie in GitHub but is-it possible to customize your package and re-build it ? There are a lot of commands that are not highlighted. I wanted to highlight the missing commands myself, then this work if you want.

Example Syntax

Like Crypto command :
crypto isakmp
crypto ipsec
crypto map

Thx for reading, have a nice day :)

Word Separators: Being overridden.

Which Syntax?:

IOS

Expected behavior and actual behavior:

I had removed the angle brackets as word separators but since this install of Network Tech a triple click on say <LAN_ADDRESS> does not include them in the selection.

Plugin blocks popups form other plugins

This plugin conflicts with other plugins which produce popups, for example it breaks functionality of SublimeText. Disabling Network Tech plugin solves the issue.

Which Syntax?:

any.

Expected behavior and actual behavior:

Expected behavior: Activate only on specific file types, do not override popups.
Actual behavior: Popups from other plugins are suppressed and thus they do not show. Disabling Network Tech plugin solves the issue.

Steps to reproduce the problem:

Install SublimeLinter, use any linter in it.
More details SublimeLinter/SublimeLinter#1116

New Feature Description:

N/A.

TwoGigabitEthernet ports not supported

Which Syntax?:

interface TwoGigabitEthernet1/0/1

Expected behavior and actual behavior:

Highlight interface and port settings

Steps to reproduce the problem:

Tw ports are not highlighted or their port settings

New Feature Description:

Highlight port settings and ports

Example Syntax

interface TwoGigabitEthernet1/0/1
description example
switchport access vlan 1000
switchport mode access
switchport voice vlan 3000
speed auto 100 1000
trust device cisco-phone
auto qos voip cisco-phone
spanning-tree portfast
service-policy input AutoQos-4.0-CiscoPhone-Input-Policy
service-policy output AutoQos-4.0-Output-Policy

Contribute to repo

Hi Glen,
I have an apple keybinding that I would like to contribute to the repo. I have also forked your project and will be creating snippets and syntax for HPE Comware, Aruba, and Fortinet Products. If you are ok, I would look forward to submitting pull requests once completed to compliment your work so far

Syntax Highlight: Authentication, Authorizing, and Accounting

Which Syntax?:

IOS

Expected behavior and actual behavior:

Highlight. Actual, none?

Steps to reproduce the problem:

Review config with AAA options set.

New Feature Description:

Would like to see highlighting of AAA configuration lines and whether it's an authentication, authorization, or accounting line. Any additional syntax highlighting would be appreciated as well.

Recommend Projects

  • React photo React

    A declarative, efficient, and flexible JavaScript library for building user interfaces.

  • Vue.js photo Vue.js

    🖖 Vue.js is a progressive, incrementally-adoptable JavaScript framework for building UI on the web.

  • Typescript photo Typescript

    TypeScript is a superset of JavaScript that compiles to clean JavaScript output.

  • TensorFlow photo TensorFlow

    An Open Source Machine Learning Framework for Everyone

  • Django photo Django

    The Web framework for perfectionists with deadlines.

  • D3 photo D3

    Bring data to life with SVG, Canvas and HTML. 📊📈🎉

Recommend Topics

  • javascript

    JavaScript (JS) is a lightweight interpreted programming language with first-class functions.

  • web

    Some thing interesting about web. New door for the world.

  • server

    A server is a program made to process requests and deliver data to clients.

  • Machine learning

    Machine learning is a way of modeling and interpreting data that allows a piece of software to respond intelligently.

  • Game

    Some thing interesting about game, make everyone happy.

Recommend Org

  • Facebook photo Facebook

    We are working to build community through open source technology. NB: members must have two-factor auth.

  • Microsoft photo Microsoft

    Open source projects and samples from Microsoft.

  • Google photo Google

    Google ❤️ Open Source for everyone.

  • D3 photo D3

    Data-Driven Documents codes.