Code Monkey home page Code Monkey logo

mwan's People

Stargazers

 avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar

Watchers

 avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar

mwan's Issues

mwan3 connection status does not recover sometimes

I have an OpenWRT TP-Link TL-WDR4300 router connected to an ADSL router. When I power cycle both devices, there is a 50% chance that WAN1 connection status stays down despite that Internet is reachable from the router. Restarting mwan3 service resolves the issue.

I tracked the problem and found the following:

several hotplug event occurs that starts other instances the connection tracker. New tracker kills older ones.

The tracker starts by pinging tracking IPs. If the ping is successful, it does not try to make sure that the wan (route) status is currently up. Here is the problem: if the status was down in the old tracker and the new tracker can reach the internet, the status stays down indefinitely (unless internet connection goes down and up again).

I suggest one of the following solutions:

1- Exit from new tracker instead of killing the old tracker (may check if the process is alive)
2- Check the wan status and change it (/sbin/hotplug-call) if it does not match the actual status.

Incompatibility with Wifidog (captive portal)

I recently setup mwan3 & Wifidog on TP Link 1043 ND with Openwrt version - CC.

On user authentication Wifidog runs following commands

iptables -t mangle -A WiFiDog_br-lan_Incoming -d 192.168.9.157 -j ACCEPT
iptables -t mangle -A WiFiDog_br-lan_Outgoing -s 192.168.9.157 -m mac --mac-source a0:99:9b:02:8b:19 -j MARK --set-mark 2

Now the commands are suppose to whitelist the client 192.168.9.157 so the internet starts to work. Ping from the client still keep getting dropped & I suspect its something to do with mwan.

ipset option ignored?

According to the documentation, it should be possible to route based on destination IP addresses in a preconfigured ipset.

Sadly, this appears to be untrue - a rule containing no other qualifiers besides an ipset option matches all outgoing packets. Looking through the source, it appears that matching based on ipsets isn't actually implemented - I can't see any match-set iptables rules being created anywhere.

Is the documentation incorrect, or am I overlooking something here?

mwan3 2.0-3 completely broken with tun ifaces

Currently trying to get 2.0-3 to function properly in LEDE. Trying the various tips suggested in the past such as setting the default gw, remove tracking IPs, etc. mwan3 insists tun0 is down because ubus returns nothing for tun... Copied my exact config from OpenWRT Chaos Calmer, from where the exact same /etc/config/openvpn, /etc/config/network, and /etc/config/mwan3 worked, to find it not working against the rewrite.

@etomm covered the issue quite well in openwrt/packages#3486 (found it after I found the same problem...) which seems to have been largely ignored. Any feedback would be appreciated @Adze1502 .

support more protocols

I recently added all protocols listed in /etc/protocols to the protocol dropdown on the luci application. I noticed, however, that the mwan3 script does not allow for anything besides icmp/tcp/udp/all.

I think the case loop should be modified to create the iptables entry for all protocols if $proto == "" or $proto == "all" and allow for the protocol to be set on anything else.

mwan3_add_rule_iptables()
{
    case $proto in
        icmp)
        iptables -I mwan3_rules $rulenumber -t mangle -p $proto -s $src_ip -d $dest_ip -m mark --mark 0/65280 $probability -j MARK --set-xmark $(($nf_mark*256))/65280 &> /dev/null
        ;;
        tcp|udp)
        iptables -I mwan3_rules $rulenumber -t mangle -p $proto -s $src_ip -d $dest_ip -m multiport --sports $src_port -m multiport --dports $dest_port -m mark --mark 0/65280 $probability -j MARK --set-xmark $(($nf_mark*256))/65280 &> /dev/null
        ;;
        *)
        iptables -I mwan3_rules $rulenumber -t mangle -s $src_ip -d $dest_ip -m mark --mark 0/65280 $probability -j MARK --set-xmark $(($nf_mark*256))/65280 &> /dev/null
        ;;
    esac
}

mwan3 2.0-3: No interface recovers from offline if all interfaces became offline

Hello,
I noticed that no interface recovers from offline if all interfaces became offline.
The test scenario if the following: two interfaces (wan and wwan), default policy is wan as primary and wwan as backup.

config interface 'wan'
	option enabled '1'
	list track_ip '8.8.4.4'
	list track_ip '208.67.222.222'
	option reliability '2'
	option count '1'
	option timeout '2'
	option interval '5'
	option down '2'
	option up '5'

config interface 'wwan'
	option enabled '1'
	list track_ip '8.8.8.8'
	list track_ip '208.67.220.220'
	option reliability '1'
	option count '1'
	option timeout '3'
	option interval '5'
	option down '3'
	option up '8'

config member 'wan_m1_w3'
	option interface 'wan'
	option metric '1'
	option weight '3'

config member 'wan_m2_w3'
	option interface 'wan'
	option metric '2'
	option weight '3'

config member 'wwan_m1_w2'
	option interface 'wwan'
	option metric '1'
	option weight '2'

config member 'wwan_m2_w2'
	option interface 'wwan'
	option metric '2'
	option weight '2'

config policy 'wan_only'
	list use_member 'wan_m1_w3'

config policy 'wwan_only'
	list use_member 'wwan_m1_w2'

config policy 'balanced'
	list use_member 'wan_m1_w3'
	list use_member 'wwan_m1_w2'

config policy 'wan_wwan'
	list use_member 'wan_m1_w3'
	list use_member 'wwan_m2_w2'

config policy 'wwan_wan'
	list use_member 'wan_m2_w3'
	list use_member 'wwan_m1_w2'

config rule 'default_rule'
	option dest_ip '0.0.0.0/0'
	option use_policy 'wan_wwan'

There is a strange thing: in this state the router sends ARP requests querying the public IP addresses defined as track_ip's.

root@Router1:~# tcpdump -qni eth1 arp
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth1, link-type EN10MB (Ethernet), capture size 262144 bytes
11:53:49.551576 ARP, Request who-has 208.67.222.222 tell 192.168.100.245, length 28
11:53:50.548220 ARP, Request who-has 0.0.0.0 tell 0.0.0.0, length 28
11:53:51.548217 ARP, Request who-has 208.67.222.222 tell 192.168.100.245, length 28
11:53:56.579945 ARP, Request who-has 0.0.0.0 tell 0.0.0.0, length 28
11:53:57.578211 ARP, Request who-has 208.67.222.222 tell 192.168.100.245, length 28
11:53:58.578210 ARP, Request who-has 208.67.222.222 tell 192.168.100.245, length 28
11:54:03.616117 ARP, Request who-has 208.67.222.222 tell 192.168.100.245, length 28
11:54:04.608211 ARP, Request who-has 208.67.222.222 tell 192.168.100.245, length 28

If I manually run 'ifup wan' then the interface recovers.
I noticed this issue for some time. Tested in OpenWrt and LEDE.
Glad to provide more info and do further testing if needed.

TIA

luci-app-mwan3 fails to install

I have downloaded packages and installed them on OpenWrt Barrier Breaker 14.07, but during the install I get this error:

Configuring luci-app-mwan3.
//usr/lib/opkg/info/luci-app-mwan3.postinst: line 4: default_postinst: not found
Collected errors:

  • pkg_run_script: package "luci-app-mwan3" postinst script returned status 127.
  • opkg_configure: luci-app-mwan3.postinst returned 127.

Trunk bug

No gateway found for interface wan2
No gateway found for interface wan3
No gateway found for interface wan1
What is the problem?

V6 support

Hi, thanks for the greate packaged mwan3! By when you will add full v6 support?

Some Android apps have problem if mwan3 started

I'm using TP-LINK WR841N v7 with OpenWrt trunk, and mwan3 1.4-19.
I have added 3 wan ports by using macvlan (so totally there are 4), and all traffic go through one cable.

If I start mwan3, these apps will get problems, even if I enable only one wan in configuration->interface, or set a rule that let all traffic go through one wan. If I stop mwan3, everything is right.

  1. Speedtest.net (https://play.google.com/store/apps/details?id=org.zwanoo.android.speedtest), an app that can test the connection speed.
    The test of download speed is OK, but the test of upload just stuck at the starting.
  2. CoolMarket (http://www.coolapk.com/apk/com.coolapk.market), it's an app market from China.
    It has an function that can help users update apps. But if I start mwan3, CoolMarket will just say no app could be updated.
    And another app market has the same problem.

Here is the troubleshooting information:
Software versions :

OpenWrt - OpenWrt Barrier Breaker r40774
LuCI - svn-r10180

mwan3 - 1.4-19
luci-app-mwan3 - 1.2-19

Output of "cat /etc/config/mwan3" :

config rule 'tcp_443_8000'
option src_ip '0.0.0.0/0'
option src_port '0:65535'
option dest_ip '0.0.0.0/0'
option dest_port '443,8000'
option proto 'tcp'
option use_policy 'one_wan_only'

config rule 'udp_443_8000'
option src_ip '0.0.0.0/0'
option src_port '0:65535'
option dest_ip '0.0.0.0/0'
option dest_port '443,8000'
option proto 'udp'
option use_policy 'one_wan_only'

config rule 'default_rule'
option src_ip '0.0.0.0/0'
option dest_ip '0.0.0.0/0'
option proto 'all'
option use_policy 'all_loadbalance'

config interface 'wan'
option enabled '1'
list track_ip '114.114.114.114'
option reliability '1'
option count '1'
option timeout '2'
option interval '5'
option down '3'
option up '5'

config interface 'wan2'
list track_ip '114.114.114.114'
option reliability '1'
option count '1'
option timeout '2'
option interval '5'
option down '3'
option up '8'
option enabled '1'

config interface 'wan3'
list track_ip '114.114.114.114'
option reliability '1'
option count '1'
option timeout '2'
option interval '5'
option down '3'
option up '8'
option enabled '1'

config interface 'wan4'
list track_ip '114.114.114.114'
option reliability '1'
option count '1'
option timeout '2'
option interval '5'
option down '3'
option up '8'
option enabled '1'

config member 'wan_wan'
option interface 'wan'
option metric '1'
option weight '1'

config member 'wan2_wan2'
option interface 'wan2'
option metric '1'
option weight '1'

config member 'wan3_wan3'
option interface 'wan3'
option metric '1'
option weight '1'

config member 'wan4_wan4'
option interface 'wan4'
option metric '1'
option weight '1'

config policy 'all_loadbalance'
list use_member 'wan_wan'
list use_member 'wan2_wan2'
list use_member 'wan3_wan3'
list use_member 'wan4_wan4'

config policy 'one_wan_only'
list use_member 'wan_wan'

Output of "cat /etc/config/network" :

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fdb2:e4d6:ddd7::/48'

config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
option dns '114.114.114.114 114.114.115.115 8.8.4.4'

config interface 'wan'
option ifname 'eth1'
option _orig_ifname 'eth1'
option _orig_bridge 'false'
option proto 'pppoe'
USERNAME HIDDEN
PASSWORD HIDDEN
option metric '10'
option peerdns '0'
option dns '114.114.114.114 114.114.115.115 8.8.4.4'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 1 2 3 4'

config interface 'wan2'
option proto 'pppoe'
option ifname 'eth2'
USERNAME HIDDEN
PASSWORD HIDDEN
option metric '20'
option peerdns '0'
option dns '114.114.114.114 114.114.115.115 8.8.4.4'

config interface 'wan3'
option proto 'pppoe'
option ifname 'eth3'
USERNAME HIDDEN
PASSWORD HIDDEN
option metric '30'
option peerdns '0'
option dns '114.114.114.114 114.114.115.115 8.8.4.4'
option ipv6 '1'

config interface 'wan4'
option proto 'pppoe'
option ifname 'eth4'
USERNAME HIDDEN
PASSWORD HIDDEN
option metric '40'
option peerdns '0'
option dns '114.114.114.114 114.114.115.115 8.8.4.4'

Output of "ifconfig" :

br-lan Link encap:Ethernet HWaddr 74:EA:3A:2B:67:11
inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::76ea:3aff:fe2b:6711/64 Scope:Link
inet6 addr: fdb2:e4d6:ddd7::1/60 Scope:Global
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:6830194 errors:0 dropped:0 overruns:0 frame:0
TX packets:6144400 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:4495622682 (4.1 GiB) TX bytes:4157915088 (3.8 GiB)

eth0 Link encap:Ethernet HWaddr 74:EA:3A:2B:67:11
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:6819705 errors:0 dropped:9 overruns:16 frame:0
TX packets:6136779 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:294854771 (281.1 MiB) TX bytes:4156794055 (3.8 GiB)
Interrupt:5

eth1 Link encap:Ethernet HWaddr 74:EA:3A:2B:67:13
inet6 addr: fe80::76ea:3aff:fe2b:6713/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:4829635 errors:0 dropped:166145 overruns:3 frame:0
TX packets:5318155 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:3387306454 (3.1 GiB) TX bytes:89191633 (85.0 MiB)
Interrupt:4

eth2 Link encap:Ethernet HWaddr 00:11:22:33:44:5E
inet6 addr: fe80::211:22ff:fe33:445e/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:205091 errors:0 dropped:0 overruns:0 frame:0
TX packets:35548 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:12411863 (11.8 MiB) TX bytes:1169136 (1.1 MiB)

eth3 Link encap:Ethernet HWaddr 00:11:22:33:44:6E
inet6 addr: fe80::211:22ff:fe33:446e/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:206650 errors:0 dropped:0 overruns:0 frame:0
TX packets:35503 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:12556833 (11.9 MiB) TX bytes:1206179 (1.1 MiB)

eth4 Link encap:Ethernet HWaddr 00:11:22:33:44:7E
inet6 addr: fe80::211:22ff:fe33:447e/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:204236 errors:0 dropped:0 overruns:0 frame:0
TX packets:35414 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:12379032 (11.8 MiB) TX bytes:1174473 (1.1 MiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:30 errors:0 dropped:0 overruns:0 frame:0
TX packets:30 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:8656 (8.4 KiB) TX bytes:8656 (8.4 KiB)

pppoe-wan Link encap:Point-to-Point Protocol
inet addr:115.228.173.0 P-t-P:115.228.160.1 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
RX packets:4511101 errors:0 dropped:0 overruns:0 frame:0
TX packets:5176846 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:3268560805 (3.0 GiB) TX bytes:4265673270 (3.9 GiB)

pppoe-wan2 Link encap:Point-to-Point Protocol
inet addr:60.163.166.155 P-t-P:60.163.166.1 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
RX packets:1393 errors:0 dropped:0 overruns:0 frame:0
TX packets:754 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:145946 (142.5 KiB) TX bytes:108105 (105.5 KiB)

pppoe-wan3 Link encap:Point-to-Point Protocol
inet addr:115.229.62.222 P-t-P:115.229.60.1 Mask:255.255.255.255
inet6 addr: fe80::89b0:37e4:72e4:253b/10 Scope:Link
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
RX packets:2569 errors:0 dropped:0 overruns:0 frame:0
TX packets:701 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:239575 (233.9 KiB) TX bytes:145652 (142.2 KiB)

pppoe-wan4 Link encap:Point-to-Point Protocol
inet addr:115.229.63.134 P-t-P:115.229.60.1 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
RX packets:1067 errors:0 dropped:0 overruns:0 frame:0
TX packets:619 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:153011 (149.4 KiB) TX bytes:116270 (113.5 KiB)

wlan0 Link encap:Ethernet HWaddr 74:EA:3A:2B:67:12
inet6 addr: fe80::76ea:3aff:fe2b:6712/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:10952 errors:0 dropped:0 overruns:0 frame:0
TX packets:1102672 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1486214 (1.4 MiB) TX bytes:231979887 (221.2 MiB)

Output of "route -n" :

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 115.228.160.1 0.0.0.0 UG 10 0 0 pppoe-wan
0.0.0.0 60.163.166.1 0.0.0.0 UG 20 0 0 pppoe-wan2
0.0.0.0 115.229.60.1 0.0.0.0 UG 30 0 0 pppoe-wan3
0.0.0.0 115.229.60.1 0.0.0.0 UG 40 0 0 pppoe-wan4
60.163.166.1 0.0.0.0 255.255.255.255 UH 0 0 0 pppoe-wan2
115.228.160.1 0.0.0.0 255.255.255.255 UH 0 0 0 pppoe-wan
115.229.60.1 0.0.0.0 255.255.255.255 UH 0 0 0 pppoe-wan3
115.229.60.1 0.0.0.0 255.255.255.255 UH 0 0 0 pppoe-wan4
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 br-lan

Output of "ip rule show" :

0: from all lookup local
1001: from all iif pppoe-wan lookup main
1002: from all iif pppoe-wan2 lookup main
1003: from all iif pppoe-wan3 lookup main
1004: from all iif pppoe-wan4 lookup main
2001: from all fwmark 0x100/0xff00 lookup 1
2002: from all fwmark 0x200/0xff00 lookup 2
2003: from all fwmark 0x300/0xff00 lookup 3
2004: from all fwmark 0x400/0xff00 lookup 4
2254: from all fwmark 0xfe00/0xff00 unreachable
32766: from all lookup main
32767: from all lookup default

Output of "ip route list table 1-250" :

1
default via 115.228.160.1 dev pppoe-wan
2
default via 60.163.166.1 dev pppoe-wan2
3
default via 115.229.60.1 dev pppoe-wan3
4
default via 115.229.60.1 dev pppoe-wan4

Firewall default output policy (must be ACCEPT) :

ACCEPT

Output of "iptables -L -t mangle -v -n" :

Chain PREROUTING (policy ACCEPT 8283 packets, 5787K bytes)
pkts bytes target prot opt in out source destination
9619 6709K mwan3_hook all -- * * 0.0.0.0/0 0.0.0.0/0
8283 5787K fwmark all -- * * 0.0.0.0/0 0.0.0.0/0

Chain INPUT (policy ACCEPT 2014 packets, 165K bytes)
pkts bytes target prot opt in out source destination

Chain FORWARD (policy ACCEPT 6255 packets, 5622K bytes)
pkts bytes target prot opt in out source destination
6255 5622K mssfix all -- * * 0.0.0.0/0 0.0.0.0/0

Chain OUTPUT (policy ACCEPT 1992 packets, 967K bytes)
pkts bytes target prot opt in out source destination
2332 1090K mwan3_hook all -- * * 0.0.0.0/0 0.0.0.0/0
2332 1090K mwan3_track_hook all -- * * 0.0.0.0/0 0.0.0.0/0

Chain POSTROUTING (policy ACCEPT 8248 packets, 6589K bytes)
pkts bytes target prot opt in out source destination

Chain fwmark (1 references)
pkts bytes target prot opt in out source destination

Chain mssfix (1 references)
pkts bytes target prot opt in out source destination
40 2088 TCPMSS tcp -- * pppoe-wan 0.0.0.0/0 0.0.0.0/0 tcp flags:0x06/0x02 /* wan (mtu_fix) / TCPMSS clamp to PMTU
7 388 TCPMSS tcp -- * pppoe-wan2 0.0.0.0/0 0.0.0.0/0 tcp flags:0x06/0x02 /
wan (mtu_fix) / TCPMSS clamp to PMTU
5 260 TCPMSS tcp -- * pppoe-wan3 0.0.0.0/0 0.0.0.0/0 tcp flags:0x06/0x02 /
wan (mtu_fix) / TCPMSS clamp to PMTU
5 272 TCPMSS tcp -- * pppoe-wan4 0.0.0.0/0 0.0.0.0/0 tcp flags:0x06/0x02 /
wan (mtu_fix) */ TCPMSS clamp to PMTU

Chain mwan3_connected (1 references)
pkts bytes target prot opt in out source destination
0 0 MARK all -- * * 0.0.0.0/0 127.0.0.0/8 mark match 0x0/0xff00 MARK or 0xff00
16 986 MARK all -- * * 0.0.0.0/0 224.0.0.0/3 mark match 0x0/0xff00 MARK or 0xff00
0 0 MARK all -- * * 0.0.0.0/0 60.163.166.1 mark match 0x0/0xff00 MARK or 0xff00
0 0 MARK all -- * * 0.0.0.0/0 115.228.160.1 mark match 0x0/0xff00 MARK or 0xff00
0 0 MARK all -- * * 0.0.0.0/0 115.229.60.1 mark match 0x0/0xff00 MARK or 0xff00
0 0 MARK all -- * * 0.0.0.0/0 115.229.60.1 mark match 0x0/0xff00 MARK or 0xff00
223 12422 MARK all -- * * 0.0.0.0/0 192.168.1.0/24 mark match 0x0/0xff00 MARK or 0xff00

Chain mwan3_hook (2 references)
pkts bytes target prot opt in out source destination
11951 7799K CONNMARK all -- * * 0.0.0.0/0 0.0.0.0/0 CONNMARK restore mask 0xff00
516 33544 mwan3_ifaces all -- * * 0.0.0.0/0 0.0.0.0/0 mark match 0x0/0xff00
433 25706 mwan3_connected all -- * * 0.0.0.0/0 0.0.0.0/0 mark match 0x0/0xff00
155 9648 mwan3_rules all -- * * 0.0.0.0/0 0.0.0.0/0 mark match 0x0/0xff00
11951 7799K CONNMARK all -- * * 0.0.0.0/0 0.0.0.0/0 CONNMARK save mask 0xff00

Chain mwan3_iface_wan (1 references)
pkts bytes target prot opt in out source destination
0 0 MARK all -- * * 115.228.160.1 0.0.0.0/0 mark match 0x0/0xff00 /* wan / MARK or 0xff00
58 6508 MARK all -- * * 0.0.0.0/0 0.0.0.0/0 mark match 0x0/0xff00 /
wan */ MARK xset 0x100/0xff00

Chain mwan3_iface_wan2 (1 references)
pkts bytes target prot opt in out source destination
0 0 MARK all -- * * 60.163.166.1 0.0.0.0/0 mark match 0x0/0xff00 /* wan2 / MARK or 0xff00
8 372 MARK all -- * * 0.0.0.0/0 0.0.0.0/0 mark match 0x0/0xff00 /
wan2 */ MARK xset 0x200/0xff00

Chain mwan3_iface_wan3 (1 references)
pkts bytes target prot opt in out source destination
0 0 MARK all -- * * 115.229.60.1 0.0.0.0/0 mark match 0x0/0xff00 /* wan3 / MARK or 0xff00
9 476 MARK all -- * * 0.0.0.0/0 0.0.0.0/0 mark match 0x0/0xff00 /
wan3 */ MARK xset 0x300/0xff00

Chain mwan3_iface_wan4 (1 references)
pkts bytes target prot opt in out source destination
0 0 MARK all -- * * 115.229.60.1 0.0.0.0/0 mark match 0x0/0xff00 /* wan4 / MARK or 0xff00
8 482 MARK all -- * * 0.0.0.0/0 0.0.0.0/0 mark match 0x0/0xff00 /
wan4 */ MARK xset 0x400/0xff00

Chain mwan3_ifaces (1 references)
pkts bytes target prot opt in out source destination
58 6508 mwan3_iface_wan all -- pppoe-wan * 0.0.0.0/0 0.0.0.0/0 mark match 0x0/0xff00
8 372 mwan3_iface_wan2 all -- pppoe-wan2 * 0.0.0.0/0 0.0.0.0/0 mark match 0x0/0xff00
9 476 mwan3_iface_wan3 all -- pppoe-wan3 * 0.0.0.0/0 0.0.0.0/0 mark match 0x0/0xff00
8 482 mwan3_iface_wan4 all -- pppoe-wan4 * 0.0.0.0/0 0.0.0.0/0 mark match 0x0/0xff00

Chain mwan3_policy_all_loadbalance (1 references)
pkts bytes target prot opt in out source destination
16 1086 MARK all -- * * 0.0.0.0/0 0.0.0.0/0 mark match 0x0/0xff00 statistic mode random probability 0.25000000000 /* wan4 1 4 / MARK xset 0x400/0xff00
20 1477 MARK all -- * * 0.0.0.0/0 0.0.0.0/0 mark match 0x0/0xff00 statistic mode random probability 0.33300000010 /
wan3 1 3 / MARK xset 0x300/0xff00
25 1691 MARK all -- * * 0.0.0.0/0 0.0.0.0/0 mark match 0x0/0xff00 statistic mode random probability 0.50000000000 /
wan2 1 2 / MARK xset 0x200/0xff00
18 1281 MARK all -- * * 0.0.0.0/0 0.0.0.0/0 mark match 0x0/0xff00 /
wan 1 1 */ MARK xset 0x100/0xff00

Chain mwan3_policy_one_wan_only (2 references)
pkts bytes target prot opt in out source destination
32 1664 MARK all -- * * 0.0.0.0/0 0.0.0.0/0 mark match 0x0/0xff00 /* wan 1 1 */ MARK xset 0x100/0xff00

Chain mwan3_rules (1 references)
pkts bytes target prot opt in out source destination
32 1664 mwan3_policy_one_wan_only tcp -- * * 0.0.0.0/0 0.0.0.0/0 multiport sports 0:65535 multiport dports 443,8000 mark match 0x0/0xff00 /* tcp_443_8000 /
0 0 mwan3_policy_one_wan_only udp -- * * 0.0.0.0/0 0.0.0.0/0 multiport sports 0:65535 multiport dports 443,8000 mark match 0x0/0xff00 /
udp_443_8000 /
79 5535 mwan3_policy_all_loadbalance all -- * * 0.0.0.0/0 0.0.0.0/0 mark match 0x0/0xff00 /
default_rule */

Chain mwan3_track_hook (1 references)
pkts bytes target prot opt in out source destination
2332 1090K mwan3_track_wan all -- * * 0.0.0.0/0 0.0.0.0/0
2296 1081K mwan3_track_wan2 all -- * * 0.0.0.0/0 0.0.0.0/0
2062 1006K mwan3_track_wan3 all -- * * 0.0.0.0/0 0.0.0.0/0
2000 972K mwan3_track_wan4 all -- * * 0.0.0.0/0 0.0.0.0/0

Chain mwan3_track_wan (1 references)
pkts bytes target prot opt in out source destination
12 1008 MARK icmp -- * pppoe-wan 0.0.0.0/0 114.114.114.114 icmptype 8 MARK or 0xff00

Chain mwan3_track_wan2 (1 references)
pkts bytes target prot opt in out source destination
12 1008 MARK icmp -- * pppoe-wan2 0.0.0.0/0 114.114.114.114 icmptype 8 MARK or 0xff00

Chain mwan3_track_wan3 (1 references)
pkts bytes target prot opt in out source destination
11 924 MARK icmp -- * pppoe-wan3 0.0.0.0/0 114.114.114.114 icmptype 8 MARK or 0xff00

Chain mwan3_track_wan4 (1 references)
pkts bytes target prot opt in out source destination
10 840 MARK icmp -- * pppoe-wan4 0.0.0.0/0 114.114.114.114 icmptype 8 MARK or 0xff00
Powered by LuCI Trunk (svn-r10180) OpenWrt Barrier Breaker r40774

mwan3 status not working correct since lede 17.01 (trunk) - interfaces status => is only "error"

Hello,
mwan3 wokring fine, but something is strange since new LEDE 17.01 (2017-10-20)
not sure, when it was still working but the status is giving only error or offline ..
but "online"

[email protected]:/root # mwan3 interfaces
Interface status:
interface 4G is error and tracking is active
interface VPN_ROUT03 is error and tracking is active
interface VPN_ROUT04 is error and tracking is active
interface VPN_ROUT05 is error and tracking is active
interface VPN_ROCCC is unknown and tracking is active
interface VPN_OTA is error and tracking is active

but on the luci they are shown as ONLINE ...
so, there is something wrong to get the correct status about the interfaces.
that was working few months ago.

pls can someone take a look ?

####################################################
version=>
[email protected]:/root # opkg list-installed | grep mwan
luci-app-mwan3 - git-17.294.24601-59a4e40-1
mwan3 - 2.6.6-1

Recommend Projects

  • React photo React

    A declarative, efficient, and flexible JavaScript library for building user interfaces.

  • Vue.js photo Vue.js

    🖖 Vue.js is a progressive, incrementally-adoptable JavaScript framework for building UI on the web.

  • Typescript photo Typescript

    TypeScript is a superset of JavaScript that compiles to clean JavaScript output.

  • TensorFlow photo TensorFlow

    An Open Source Machine Learning Framework for Everyone

  • Django photo Django

    The Web framework for perfectionists with deadlines.

  • D3 photo D3

    Bring data to life with SVG, Canvas and HTML. 📊📈🎉

Recommend Topics

  • javascript

    JavaScript (JS) is a lightweight interpreted programming language with first-class functions.

  • web

    Some thing interesting about web. New door for the world.

  • server

    A server is a program made to process requests and deliver data to clients.

  • Machine learning

    Machine learning is a way of modeling and interpreting data that allows a piece of software to respond intelligently.

  • Game

    Some thing interesting about game, make everyone happy.

Recommend Org

  • Facebook photo Facebook

    We are working to build community through open source technology. NB: members must have two-factor auth.

  • Microsoft photo Microsoft

    Open source projects and samples from Microsoft.

  • Google photo Google

    Google ❤️ Open Source for everyone.

  • D3 photo D3

    Data-Driven Documents codes.